Prerequisites and RequirementsΒΆ

The following are prerequisites for using Telemetry Streaming:

  • You must be using BIG-IP version 13.1 or later to use Telemetry Streaming. Telemetry Streaming is not intended to work on BIG-IP versions that have reached End of Life. See here for more information about BIG-IP versions supported by F5.
  • To install and configure Telemetry Streaming, your BIG-IP user account must have the Administrator role.
    • See the Prometheus Pull Consumer documentation for more information on configuring a read-only account for pull consumers
  • You must have a configured consumer that will receive the data.
  • You should be familiar with the F5 BIG-IP and F5 terminology. For general information and documentation on the BIG-IP system, see the F5 Knowledge Center.